Project

General

Profile

Actions

Bug #229

closed

Access violations hanging xbox on video stream playback end with TVCatchup plugin

Added by Smiff over 11 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Video playback (inc. audio in
Target version:
Start date:
03/01/2013
Due date:
% Done:

0%

Resolution:
fixed
Affected Version:

Description

If you play a stream for any length of time approx >5 minutes (?) then stop playback, the xbox hangs.
It still responds to ftp, but video seems to be hung forever on the wait animation, requires a power reset.

tested:
Not skin related.
happens with all recent versions of x4x i've tried (around 3.2 to 3.2.1)
haven't seen this with any other plugins so far.

workaround: go to menu before pressing STOP. hang also happens if stream dropped due to network issues.

for discussion i have threads here
http://forums.tvcatchup.com/showthread.php?11068-plugin-causing-exceptions-on-x4x
http://www.xbmc4xbox.org.uk/forum/viewtopic.php?f=7&t=842&p=9111#p9111

e.g.
"ERROR: CThread::staticThread : Access violation at 0x1e050139: Reading location 0x0000000c"

example log
http://pastebin.com/C8YiKhru

thanks, first bug report hope this is ok.


Files

tvcatchup-1.4.8.zip (229 KB) tvcatchup-1.4.8.zip buzz, 12/26/2013 04:41 PM
Actions #1

Updated by buzz over 11 years ago

  • Priority changed from Normal to High
  • Target version set to Future / Pending

Thanks. exactly how I like a bug report - with all the information to reproduce etc. Although I have a feeling this one might be tricky to track down.

Actions #2

Updated by buzz about 11 years ago

debug log is gone now - did you set it for a limited time? how does this work with the latest svn build?

Actions #3

Updated by buzz about 11 years ago

  • Affected Version changed from 3.2 to 3.3
Actions #4

Updated by buzz over 10 years ago

  • Status changed from New to Feedback
  • Assignee changed from buzz to Smiff
  • Priority changed from High to Normal

are you able to try this with the latest nightly build ? it may well be it is resolved with the latest python code.

Actions #5

Updated by Smiff over 10 years ago

just tried with XBMC4XBOX-32643
sorry it seems to hang in same way:

20:58:58 M: 21782528   ERROR: Error Type: <type 'exceptions.IOError'>
20:58:58 M: 21782528   ERROR: Error Contents: close() called during concurrent operation on the same file object.
20:58:58 M: 21782528   ERROR: Traceback (most recent call last):
                                              File "Q:\plugins\video\TVCatchup\default.py", line 82, in <module>
                                                settingsfile2.close()
                                            IOError: close() called during concurrent operation on the same file object.
Actions #6

Updated by buzz over 10 years ago

sorry but you need to upload a new full log as the old one is now gone. With any error I need to reference lots of things in the logs, such as versions of software, skins in use, script/plugin versions etc. I don't know which version of the tv catchup extension you are running for example.

Actions #7

Updated by buzz over 10 years ago

I have played video back from a couple of channels usnig attached plugin v1.4.8 (taken from the tvcatchup website with a minor change for compatibility with xbmc4xbox addon emulator). I watched both channels for more than 5 mins and then stopped the video playback. After a short pause it returned fine to the channel list.

Actions #8

Updated by buzz over 10 years ago

forgot attachment.

Actions #9

Updated by Smiff over 10 years ago

ok with plugin 1.48 and dev build 32643 it seems to be fixed. sometimes pauses for a while but always seems to go back to menu eventually. i may have got some hangs but can't recreate today. can anyone else confirm fixed?

Actions #10

Updated by buzz over 10 years ago

I would be interested to know if the older plugin that used to crash still crashes with 3.5 beta 2 as I fixed a bug that caused some problems with python scripts.

Actions #11

Updated by Smiff over 10 years ago

yes i got a hang with the older ver of plugin, also on 32643, on first attempt actually. sorry for delay updating this! thanks. do you want me to install newer build now?

Actions #12

Updated by buzz over 10 years ago

32643 is older than 3.5 beta 2 - and before I have done the fix for the freezing. I am interested in a test against 3.5 beta 2 or newer. Cheers.

Actions #13

Updated by Smiff over 10 years ago

sorry, half asleep.

yes get the same hang in 3.5b2, also first attempt (ran for ~5 mins then Stop), using older plugin (1.4.3 I think?).
hope i'm giving it long enough to unfreeze, ~3 minutes and no ui response is enough?
as before i can still connect on FTP.

Actions #14

Updated by buzz about 10 years ago

not sure then, but since it works on the newer version, ill leave this for now. alternatively I will need another debug log with the latest build. thanks.

Actions #15

Updated by buzz about 10 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

this should be fixed as of the currently nightly builds.

Actions

Also available in: Atom PDF